AK Rifles banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have done several other yugos m85/m92 with no problems so I am kind of stumped here.
This is the second time I have worked this gun and in between efforts replaced to new park solution and new clean aluminum oxide blasting media. I Cleaned up everything well etc etc.
The problem I am having is the front sight/gas block and the rear top cover hinge block. They just will not take the park on neither the 1st or 2nd attempt. I used Palmetto solution the 1st time and Shooter solution the second. The rest of the gun looks great.
Any thoughts?
Thanks muchly
 

·
Registered
Joined
·
1,242 Posts
what was the original finish on those parts? sometimes a blued part needs a quick acid bath to take park evenly.
 

·
Registered
Joined
·
3,528 Posts
When Parkerizing, I grit blast off the old finish.
I wonder if the metal in those 2 parts could be that dramatically different that they park different?
 

·
Registered
Joined
·
1,242 Posts
Also remember to degrease the parts thoroughly, oils will contaminate your park solution and prevent parts for coming out right.
 

·
Registered
Joined
·
1,660 Posts
Give the parts a quick pickle treatment in muriatic acid bath diluted with water 4 to 1 or use a pre=black dip. I use Lauers pre=black dip for zinc park...it is basically a pre mixed weak pickling solution with additives. If the metal is not reacting it is not ferric (we know it is) or there is a coating or contaminant on the metal.
 
1 - 5 of 5 Posts
Top