AK Rifles banner

1 - 7 of 7 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
I just finished assembly of my Polish AKMS and my Romy AIM-63 tonight. Polish went together on a Ewbanks receiver after a lot of adjustment. The problem is with the Romy on a Global Trades. Everything went very smoothly. My holes all matched up, length of the receiver was good, mag opening was perfect, dropped the bolt/bolt carrier in and they were smooth as silk with no adjustment. Sounds great right? Well, when I put in the trigger group (G2), I racked the carrier and it popped out of the top rail towards the back of the receiver. It happens every time I pull it back. It seems to be from the notches that GT puts in for the bolt to enter the receiver and the pressure from the hammer. Has this happened to anyone else? What would you recommend? Am I screwed? :sad:

Thanks,

St
 

·
Registered
Joined
·
185 Posts
na its an easy fix

first the cause (so you wont do it again :goof: )
the rear tang is installed alittle to far back
you prob installed the front trunnion alittle to far back
and from there everythang got shifted back
sometimes 1/32 is the diff between kickass and lickass

first fix
put a small tack in the back of the recoil ass so the carrier cant go back as far when it is installed this is the most perm and the way i would go

second fix
install a buffer works but if the buffer ever breaks or you take it out the rifle wont function

third fix
install a rpk recoil ass either kind
they dont allow the carrier to move up and pop out this wont always fix your prob tho and they can be spendy
 

·
Registered
Joined
·
92 Posts
Discussion Starter #3
I don't have access to a welder so I went ahead and ordered a couple buffers. I'll let you know how it goes. I'm not sure if the carrier will pop out while firing, but I'm going to go try it out tomorrow.

Thanks,

St
 

·
Registered
Joined
·
92 Posts
Discussion Starter #5
Well, it's official. My Romy won't cycle using ammo. Will post more after I receive my buffers. On a brighter side... My AKMS bump fires beautifully..... :twisted:
 

·
Registered
Joined
·
92 Posts
Discussion Starter #6
Buffer fixed the problem. I'll be taking her out and breaking her in next weekend.

:grin:

I did notice something new after I got the pop-out issue solved. I found that the bolt/carrier would hang up really badly on the G2 FCG. I looked at the hammer on my RSA FCG and found that it was a lot different. I re-shaped the end of the G2 hammer being careful not to change where it contacts the firing pin. It glides now. Is this a common problem with the G2?

-St
 

·
Registered
Joined
·
1,242 Posts
I have noticed that on the G-2 there is a cast lineright down the center of the hammer.I noticed this after it left a line on the surface of my bolt carrier that contacts it. I lightly file this then polish the hammer face add a little clp and work the action back and forth about 25 times...smooths it right out. I wouldn't really grind the hammer face(like century did on my sar 3) I think this might harm the heat treating of the hammer.
 
1 - 7 of 7 Posts
Top