AK Rifles banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just finished a "getto" build with a Bulgarian parts kit, when I first took it to the range I was thinking it had a gas flow problem because the bold would only go back about half way and the spent cartriage would get stuck facing up ward between the bolt and the dust cover. So I tryed taking the dust cover off and now the gun works fine, full stroke of the bolt carrier and full extraction, ejection and feed. Any idea what the problem could be? If I had to guess it is caused by the case being ejected to far upward, but I'm not sure.



Thanks guys!
 

·
Registered
Joined
·
1,357 Posts
Was this built on a Flat? Sounds like the ejector rail is alittle too far back causing the case to be ejected too late in the stroke hitting the top cover and knocking it back into the action instead of out and away. Other possibility if built on a flat that side of your receiver is warped outward causing the ejector to catch only the outside rim of the case. The center support rivet spacers from Ak-builder need to be trimmed a few thou before installing into your receiver Otherwise will spread your receiver out and the ejector will not work properly.
 

·
Registered
Joined
·
2,096 Posts
Had a Yugo where the recoil spring guide was just a little goofy and it caused a similar problem. Put a different one in and it worked fine.

Weird thing was I put the goofy one in another AK to double check but it worked fine there.
 
1 - 4 of 4 Posts
Top