AK Rifles banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Are the Muzzle Brakes on the Century Built Yugo M70AB2 permanently mounted? I know the plunger detent seems to move but the Brake does not want to move and I don't want to force it. I had an idea that I might want to remove it to use my blank adapter. Thanks in advance for any info.

Roger
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Yes, I understand! I should have mentioned that this has been an effort to remove in the clockwise direction( LH). I just wanted to know if Century did something to make it permanent. From the side view the brake looks as if it was installed slightly canted. Possibly cross threaded? Maybe it's baked on by all the hot gases and fouling expelled. I could soak the whole muzzle in a container of Kroil for several days if this is the problem.
 

·
Registered
Joined
·
392 Posts
Mine came off very easily. I just pushed down on the silver "button" and twisted he muzzle brake off. Maybe it is cross threaded?
 

·
Banned
Joined
·
1,611 Posts
There are quite a few of these with "fixed" muzzle devices.

I had one and while the detent pin would move, the slant brake would not (and I didn't feel like putting the vise grips to work on it).
 

·
Banned
Joined
·
2,301 Posts
Visegrips worked on mine, first soaked it muzzle down in a cup of blaster for a day, then padded it with a few folds of a sock and clamped on hard. Took some love taps on the visegrips with the cement floor but it screwed off. It was beautiful underneath, just very tight with that C marked brake. Funny thing is that slant works great now on any other rifle, and the yugo has a nice snug fit with any other muzzle device, they go on by hand but don't wobble.
 

·
Registered
Joined
·
206 Posts
My slant brake 'jiggles' a bit! It won't spin while the button is out and it will LH unscrew with no problems after the button is pushed. It won't tighten to the right enough to re-engage the lock notch. Is this good, bad or just ok?
 

·
Registered
Joined
·
297 Posts
RocketFoot said:
My slant brake 'jiggles' a bit! It won't spin while the button is out and it will LH unscrew with no problems after the button is pushed. It won't tighten to the right enough to re-engage the lock notch. Is this good, bad or just ok?
don`t worry about it. i have two yugos one is thght the other won`t quite go the last quarter inch to be tight so it is a wiggler.
 
1 - 9 of 9 Posts
Top